/ Forside/ Teknologi / Administrative / MS-Office / Spørgsmål
Login
Glemt dit kodeord?
Brugernavn 

Kodeord  


Reklame
Top 10 brugere
MS-Office
#NavnPoint
sion 18609
refi 14474
Klaudi 8489
Rosco40 5695
berpox 5456
dk 5398
Benjamin... 4870
webnoob 4747
o.v.n. 4637
10  EXTERMINA.. 4373
Find et tal i excel
Fra : anders_bak
Vist : 3570 gange
100 point
Dato : 25-01-06 15:01

Jeg prøver at fine ud af hvordan jeg laver en udvidelse af den almindelige "hvis" funktion i excel.

et lille eksempel:

Jeg har en række tal stående i feltet A1 til A25 (altså 25 forskellige værdier). i felt B1 har jeg en værdi. Jeg skal nu finde ud af om værdien i B1 også forekommer i et af felterne A1:A25, og retunere værdierne 0 eller 1 i C1 alt efter om værdien findes eller ej.

Det er jo oplagt at bruge "hvis" funktionen i dette tilfælde, men jeg kan sgu ik' hit' ud af hvordan jeg får den til at søge i alle 25 felter istedet for kun 1.

 
 
Kommentar
Fra : sion


Dato : 25-01-06 15:12

Du skal bruge denne formel: {=HVIS(B1=A1:A25;1;0)}

Tuborg-klammerne ("{" og "}") er vigtige, da de fortæller Excel, at der skal søges i en matrix (altså flere celler, her A1:A25). Du laver tuborg-klammerne ved at afslutte formelindtastningen med Ctrl+Shift+Enter i stedet for kun Enter.

Simon

Accepteret svar
Fra : sion

Modtaget 110 point
Dato : 25-01-06 15:15

Altså du indtaster =HVIS(B1=A1:A25;1;0) og afslutter med Ctrl+Shift+Enter.

Simon - igen

Kommentar
Fra : fdbm


Dato : 25-01-06 15:27

Det duer da vist ikke, Simon. Eks.: Med værdien 3 i A3 og værdien 3 i B1 returneres værdien 0 i din formel, selv om der er sammenfald på A3 og B1. Den ønskede resultat var jo at fåe en SAND værdi i C1.

Frank

Godkendelse af svar
Fra : anders_bak


Dato : 25-01-06 15:34

Tak for svaret sion.

Kommentar
Fra : henrikdj


Dato : 25-01-06 15:49

Frank har da vist ret - jeg kan heller ikke få det til at virke ud fra din beskrivelse, Simon!

Kommentar
Fra : sion


Dato : 25-01-06 15:59

I har ret. Der kommer en løsning om fem minutter...

Simon

Kommentar
Fra : sion


Dato : 25-01-06 16:03

Brug denne formel: =HVIS(TÆL.HVIS(A1:A25;B1)>0;1;0)

Den er også lidt mere simpel.

Beklager, at jeg var lidt for hurtig før.

Simon

Kommentar
Fra : Brassovitski


Dato : 25-01-06 16:14

Halløjsa
Brug Lopslag funktionen inden i en hvis funktion, det burde kunne virke.

Kommentar
Fra : henrikdj


Dato : 25-01-06 16:18

Ja nu blev jeg jo stædig (selvom der ikke er nogen point at hente)

Jeg ville foreslå at lave et Lopslag i matrixen og teste på om det returnerede #I/T - og så indlejre det i en Hvis der returnerede 1 eller 0.

Således:
=HVIS(ER.IKKE.TILGÆNGELIG(LOPSLAG(B1;A1:A25;1;FALSK));1;0)

Kommentar
Fra : henrikdj


Dato : 25-01-06 16:24

men din løsning virker også, Simon

Kommentar
Fra : fdbm


Dato : 25-01-06 17:20

Din løsning med LOPSLAG vorker jo ikke rigtigt, henrikdj- der returneres jo et 0 som svar, mens det ønskede svar var 1 (eller JA).

Men for nu at tage et skridt videre, kunne det måske være sjovt at finde ud af, om Simon's løsning kunne udbygges til også at pege på den/de givne celle(r) i matrix'en, der indeholder den eftersøgte B1-værdi. Jeg er i hvert fald nysgerrig, da jeg såmænd har haft det behov.

Vil det ikke også være muligt, Simon ?

Kommentar
Fra : henrikdj


Dato : 25-01-06 19:39

FDBM: jo den gør - du kan da bare bytte om på 0 og 1 sidst i formlen efter ønske...

iøvrigt var Anders' spørgsmål da netop formuleret så 0=sand/ja

mht til dit spm med at pege - har du dyrket Sammenlign funktionen - den returnerer jo netop den relative placering i en matrix udfra en given værdi.

mvh
Henrik

Du har følgende muligheder
Eftersom du ikke er logget ind i systemet, kan du ikke skrive et indlæg til dette spørgsmål.

Hvis du ikke allerede er registreret, kan du gratis blive medlem, ved at trykke på "Bliv medlem" ude i menuen.
Søg
Reklame
Statistik
Spørgsmål : 173374
Tips : 31646
Nyheder : 719565
Indlæg : 6381775
Brugere : 218246

Månedens bedste
Årets bedste
Sidste års bedste