/ Forside/ Teknologi / Multimedie & design / Flash / Spørgsmål
Login
Glemt dit kodeord?
Brugernavn 

Kodeord  


Reklame
Top 10 brugere
Flash
#NavnPoint
bentjuul 4251
molokyle 1978
Klaudi 1488
jhvp 1265
pallenoc 1160
katekismus 1020
Fnollerpi.. 790
slander 510
Dr.Disco 500
10  Flash77 500
problem m æ,ø,å i extern txt fil
Fra : naedde
Vist : 922 gange
40 point
Dato : 24-04-05 20:05

Hej:)
Jeg har en extern textfil i flash MX professionel 2004 - som ikke kan afkode æ,ø og å. Jeg har hørt at man kan eksportere i en ældre version for at undgå problemet, men da jeg bruger loadClip i mine scripts duer det ikke...

Nogen der kan hjælpe mig?

På forhånd tak:)

 
 
Kommentar
Fra : perchris


Dato : 24-04-05 21:30

Hvis det bare er ren tekst, så kopier det hele til clipboard, past det hele ind i en fil der kan afkode æ,ø og å.
vises de ikke rigtig så brug søg og erstat. Husk både store og små bogstaver samt andre tegn der ikke er korrekte.
fx. find et sted hvor der skulle være et "æ", kopier og paste ind i søg og skriv æ i erstat.


Kommentar
Fra : arne.jakobsen


Dato : 24-04-05 23:41

naedde - Jeg kender ikke det format du henviser til "extern textfil i flash MX professionel 2004", der findes jo mange forskellige formater idag. Men hvis du har lyst, kan du sende filen til mig på hca@inet.dk - så skal jeg prøve at hjælpe dig. Hilsen Arne

Kommentar
Fra : bentjuul


Dato : 25-04-05 19:10

Du skal sætte følgende ind i dit ActionScript

Kode
System.useCodepage = true;


//bentjuul

Kommentar
Fra : naedde


Dato : 26-04-05 07:56

Kære Hjerner:)
Jeg prøver lige at forklare mig lidt bedre..
Jeg har i flash (MX pro 2004) et dynamisk tekstfelt, der henter tekst ind fra en ekstern textfil (skrevet i notepad).

I flash har jeg sat mit dynamiske tekstfelt til font: _sans
og i keyframe 1: System.useCodepage=true;

Den tekstfil (notepad) der loades ind er sat til:
font:verdana
script: western
- og gemt med UTF-8 encoding

Når jeg åbner textfilen i Notepad ser den rigtig ud (med æ,ø og å) - det er først når den loades ind i swf filen, problemet opstår (æ,ø og å mangler).

Hvad kan der være galt???

På forhånd tak for hjælpen:)

Kommentar
Fra : bentjuul


Dato : 26-04-05 10:10

Jeg kan jo ikke se din .fla fil, så det kan være lidt svært at sige hvad der er galt, men til mine eksterne tekstfiler bruger loadVars.
Jeg mener dog at du bør bruge Notesblok til dine eksterne txt filer og her skal du bare bruge Notesblok standardskrift og gemme txt filen som Ansi og som .txt

Men du kunne prøve følgende og sætte dette ind i første frame på en helt ny .fla fil for at se om du kunne få det til at virke.
Kode
System.useCodepage = true;
mineData = new LoadVars();
mineData.onLoad = function(){
minText.text = this.indhold;
}
mineData.load("ekstern.txt");

mineData.onLoad = function(success){
   if (success) {
      minText.htmlText = this.indhold;

   } else {
      minTekst.htmlText = "error loading variables";
   }
}

stop()


Så laver du en ekstern txt fil og gemmer den som jeg tidligere beskrev som Ansi og giver den navnet ekstern.txt, hvis du vælger et andet navn, så må du rette det i Actionscriptet.

Din tekst skal starte med indhold= som her
Kode
indhold=Nu kommer al din tekst med æ ø og å og du kan bruge html tags i teksten som f.eks her <font color="#0000FF">hvor denne tekst bliver blå</font>


Ovenstående har jeg afprøvet og det virker. Jeg håber det kan være dig til hjælp.

//bentjuul

Accepteret svar
Fra : bentjuul

Modtaget 40 point
Dato : 26-04-05 12:22

Jeg glemte lige at skrive - hvis du bruger ovenstående kode, at det dynamiske tekstfelt skal have navnet: minText hvis du giver det et andet navn, så husk at ændrer koden.

Jeg kan se at du også har lagt spørgsmålet på eksperten - og da jeg først er på kandu igen på søndag - så kan du sikkert få hjælp der hvis ovenstående kode skulle give dig problemer. Hvis du vil have det, kan jeg sende dig ovenstående kode til dig som .fla, du finder min mail under min profil.

//bentjuul

Kommentar
Fra : naedde


Dato : 28-04-05 17:19

Nu virker det! Jeg fandt én der havde oplevet det samme - og det er åbenbart noget der kan ske, når en fla fil stammer fra en ældre version af flash... Det virkede da jeg lavede en helt ny fla fil med alle de samme elementer og koder.
Så tak for gode ideer og tålmodighed - og gi' gerne tippet videre til andre stakler med samme problem...

Pointene går til sidste bentjuul - for flest indlæg;)

tak for hjælpen!

Godkendelse af svar
Fra : naedde


Dato : 28-04-05 17:23

Tak for svaret bentjuul - fedt at du gad gøre så stor en indsats:)
                        

Kommentar
Fra : bentjuul


Dato : 01-05-05 15:58

Tak for det naedde - men jeg tænkte om du bruger html tags i din externe tekstfil - for det kan du med mit forslag.

//bentjuul

Kommentar
Fra : naedde


Dato : 02-05-05 17:13

Ja det gør jeg - det virker også med mine egne koder (som minder meget om dit forslag) :)

Du har følgende muligheder
Eftersom du ikke er logget ind i systemet, kan du ikke skrive et indlæg til dette spørgsmål.

Hvis du ikke allerede er registreret, kan du gratis blive medlem, ved at trykke på "Bliv medlem" ude i menuen.
Søg
Reklame
Statistik
Spørgsmål : 177350
Tips : 31960
Nyheder : 719565
Indlæg : 6407379
Brugere : 218867

Månedens bedste
Årets bedste
Sidste års bedste