/ Forside/ Teknologi / Netværk / Andet Netværk / Spørgsmål
Login
Glemt dit kodeord?
Brugernavn 

Kodeord  


Reklame
Top 10 brugere
Andet Netværk
#NavnPoint
severino 8906
EXTERMINA.. 3925
Fijala 3451
o.v.n. 3039
webnoob 2690
BjarneD 2390
e.c 1886
pallebhan.. 1728
srhansen 1720
10  dk 1610
0 TTL - Cisco 667 - NAT
Fra : NeuRo
Vist : 226 gange
275 point
Dato : 17-04-04 18:19

Hej

Jeg har opsat en Microsoft Windows 2003 maskine, hvor jeg har installeret Microsofts indbyggede DNS. DNS serveren er opsat korrekt, men jeg har et problem med at når jeg prøver at resolve f.eks. 'test.eblue.dk':

http://www.dk-hostmaster.dk/dkhostcms/bs?ip=&host=test.eblue.dk&ns=route-1.ns.eblue.dk&pageid=78&action=cmsview&lang=da

Så får jeg at vide at min TTL er 0, og dette er ikke tilfældet. Den er opsat til 1 dag inde i DNS serveren.

Jeg har været rundt på nettet og fandt denne artikel:

http://groups.google.dk/groups?hl=da&lr=&ie=UTF-8&oe=UTF-8&threadm=9dcpcr%24ka9%241%40slb4.atl.mindspring.net&rnum=20&prev=/groups%3Fq%3DA%2Brecord%2Bhas%2Bzero%2Bttl%26start%3D10%26hl%3Dda%26lr%3D%26ie%3DUTF-8%26oe%3DUTF-8%26selm%3D9dcpcr%2524ka9%25241%2540slb4.atl.mindspring.net%26rnum%3D20

Det lyder som om det er samme problem som mit, men de har desværre INGEN løsning på problemet i den tråd. :( Altså jeg tror problemet hænger sammen med at jeg kører NAT på min Cisco 667 router. Jeg forwarder udp/tcp for port 53 til DNS serveren natuligvis, men det er tilsyneladende ikke nok?!???

Jeg er virkelig i vildrede, da jeg med succes har installeret mailserver + webserver og blot forwardet portene til maskinen, men det virker altså ikke med DNS serveren :(

Jeg håber nogen kan komme med svaret til mig, da jeg har ledt og ledt ..... Og er helt i vildrede.

På forhånd tak!!!

Mvh. Thomas

 
 
Kommentar
Fra : linuxrules


Dato : 17-04-04 22:54

Jeg har lige prøvet at lave en telnet på port 53 som er den.
Der får den fat i et eller andet.
Det tyder på at din nat virker.
Derunder er et navneopslag på din dns server

> server 212.242.50.86
Default Server: port21.ds1-rd.adsl.cybercity.dk
Address: 212.242.50.86

> 212.242.50.86
Server: port21.ds1-rd.adsl.cybercity.dk
Address: 212.242.50.86

DNS request timed out.
timeout was 2 seconds.
*** Request to port21.ds1-rd.adsl.cybercity.dk timed-out
> eblue.dk
Server: port21.ds1-rd.adsl.cybercity.dk
Address: 212.242.50.86

Name: eblue.dk

Din server kender godt nok eblue.dk
Med den ved ikke at den selv hedder 212.242.50.86
Jeg ville sætte dit offentelige ip nummer ind i din dns med det navn din dns skal have
(Husk at lave en revesre record.)

Hvis den skal stå som en ægte dns hos dkhostmaster skal du huske først at få den registreret hos dkhostmaster (koster 500,- ex. moms)
og dernæst få dem til at lave en gluerecord.


Jesper

Kommentar
Fra : NeuRo


Dato : 18-04-04 10:30

Kan du uddybe det med at lave reverse record ?? Og hvad mener du med at sætte mit offentlige ip nummer i min dns? Jeg har oprettet navnet på min dns i eblue.dk, altså route-1.ns.eblue.dk er oprettet og peger på min offentlige ip adresse.

Jeg er godkendt som Zone kontakt hos DK Hostmaster, og en GLUE record laver de vel selv når man godkendes?


Kommentar
Fra : NeuRo


Dato : 18-04-04 10:39

Altså jeg har følgende A record: route-1.ns som peger på 212.242.50.86

Ja, mit NAT og port forwarding virker som det skal, da jeg har kørt mailserver + webserver i et årstid på den uden problemer .... Jeg læste bare på nettet at der var nogle særlige problemer med Cisco's CBOS også det at kører NAT + DNS server :/ Men det mener du ikke har noget på sig eller?

Jeg vil som nævnt i tidligere kommentar, meget gerne have en uddybende forklaring på det du skrev, da jeg stadig er newbee mht. DNS opsætning og sådan :)

Kommentar
Fra : NeuRo


Dato : 18-04-04 10:58

Eksempel på min Zone fil:

;
; Database file eblue.dk.dns for eblue.dk zone.
; Zone version: 150
;

@ IN SOA route-1.ns.eblue.dk. mail.eblue.dk. (
   150 ; serial number
   36000 ; refresh
   600 ; retry
   86400 ; expire
   3600 ) ; default TTL

;
; Zone NS records
;

@ NS   secondary.infoserv.dk.
secondary.infoserv.dk. A   195.249.146.7
@ NS   route-1.ns.eblue.dk.

;
; Zone records
;

@ MX   10   mail.eblue.dk.
ftp A   212.242.50.86
localhost A   127.0.0.1
mail A   212.242.50.86
route-1.ns A   212.242.50.86
services A   212.242.50.86
test A   195.249.146.7
www A   212.242.50.86


Kommentar
Fra : NeuRo


Dato : 18-04-04 11:45

dns serveren er sat rigtigt op for hvis jeg laver nslookup og bruger server 10.0.0.2 ... og spørger ... så resolver den korrekt. så det er når jeg spørger GENNEM routeren at det går galt, altså bruger server 212.242.50.86 :(

Kommentar
Fra : NeuRo


Dato : 18-04-04 17:35

Jeg snakkede med Cybercity, og vi fik løst mit problem ved at lave et trick med at sende alt port 53 trafik videre til serveren igennem end anden port.

Ellers tak for hjælpen.

Du har følgende muligheder
Dette spørgsmål er blevet annulleret, det er derfor ikke muligt for at tilføje flere kommentarer.
Søg
Reklame
Statistik
Spørgsmål : 173562
Tips : 31660
Nyheder : 719565
Indlæg : 6383030
Brugere : 218252

Månedens bedste
Årets bedste
Sidste års bedste