/ Forside/ Teknologi / Multimedie & design / Dreamweaver / Spørgsmål
Login
Glemt dit kodeord?
Brugernavn 

Kodeord  


Reklame
Top 10 brugere
Dreamweaver
#NavnPoint
bentjuul 2364
molokyle 1030
BoJohansen 912
dk 650
ajohansen 520
jakjoe 500
netop 500
LisBJensen 345
CLAN 336
10  basil28 320
Print af links
Fra : evigsommer
Vist : 345 gange
100 point
Dato : 05-04-03 22:06

Hej alle!

Jeg bruger Dreamweaver MX og har et print-javaskript på min side. Men det vil ikke printe links på siden ud (linkene springes over). Hvad gør jeg? Er lidt af en amatør. Håber, I kan hjælpe.

Mvh.

Klaus

 
 
Kommentar
Fra : LisBJensen


Dato : 05-04-03 22:45

Måske skulle du give en adresse til din side, så der er en mulighed for at se hvad du har gjort forkert / eller skulle have gjort anderledes.

Lis

Kommentar
Fra : evigsommer


Dato : 05-04-03 23:03

Hej Lis!

Sidens adresse er: http://home19.inet.tele.dk/nymorgen/

Mvh.

Klaus


Kommentar
Fra : LisBJensen


Dato : 05-04-03 23:18

Næste spørgsmål, på hvilken side finder jeg det du vil have skrevet ud?

Lis

Kommentar
Fra : evigsommer


Dato : 05-04-03 23:30

Hej Lis!

Jeg kører med templates, så hvad der gælder for én af siderne, gælder for alle. Tag derfor fx denne side, hvor der er links i selve teksten, som ikke bliver skrevet ud, ej heller Home øverst eller det nederste link til nyhedsbureauet: http://home19.inet.tele.dk/nymorgen/artikler/verdenrundt/2003-0113-nordkorea.htm

Mvh.

Klaus



Kommentar
Fra : LisBJensen


Dato : 06-04-03 00:43

Hej Klaus
Har du lavet den funktion der skal sørge for at printe?

Hvis nej, så send mig din mailadresse på lis.jensen@stofanet.dk



Kommentar
Fra : evigsommer


Dato : 06-04-03 00:51

Hej Lis!

Forstår ikke, hvad du mener. Klikker du på print-ikonet, kører printet okay, men det er blot linkene, som ikke kører. Jeg har ikke selv lavet nogen printfunktion, men blot taget et java-skript fra en side og sat ind i html-koden.

Mvh.

Klaus

Kommentar
Fra : LisBJensen


Dato : 06-04-03 01:02

Hej Igen Klaus.
Når jeg printer din side får jeg alt hvad der står, ogdå linkene, men selvfølgelig står der jo ikke den url du har gemt bag linket.

Dette kan være din printeropsætning eller forsi du kører en ældre browser.
Bruger du IE eller netscape som Browser?

Lis

Kommentar
Fra : evigsommer


Dato : 06-04-03 01:17

Hej Lis!

Jeg kører IE6. Så er det printeren måske?

Klaus

Kommentar
Fra : LisBJensen


Dato : 06-04-03 01:25

Ja, så tror jeg du skal se på Hvad der står i det skærmbillede du får frem når du trykker på printikonet. Jeg får disse ting med:
Header (det du har skrevt i Tile-taggen
home + printikon
hele teksten incl linktekster eks. "Resolution" - (http://www.iaea.org/worldatom/Press/P_release/2003/gov2003-3.pdf) er det der ligger bagved, og som ikke udskrives.
Footer = det sted hvorfra siden er udskrevet i dette tilfælde http://home19.in.................

Hilsen Lis

Kommentar
Fra : evigsommer


Dato : 06-04-03 01:35

Når jeg klikker på printikonet, kommer print-vinduet op, og jeg kan trykke print. Jeg har åbnet siden i notepad og kan se det samme som dig. "Resolution" er der ikke. Men hvorfor er det ikke det? Det er jo hele spørgsmålet. Hvordan skal jeg linke, således at "resolution" kommer med?

Klaus

Kommentar
Fra : LisBJensen


Dato : 06-04-03 01:45

Hej Klaus.
Det står på siden når du kigger dette i notepad, kig efter dette:

<p>USA tilskyndede Det Internationale Atomenergi Agentur (IAEA) til at vedtage
endnu en
<a ref="http://www.iaea.org/worldatom/Press/P_release/2003/gov2003-3.pdf" target="_blank">&quot;resolution&quot;</a>

imod DPRK den 6. januar i k&oslash;lvandet p&aring; en lignende &quot;resolution&quot;
fra den 29. november 2002.</p>

Dit link er OK Hvis du vil prøve noget så fjern " og erstat med ' eller ingenting - dit link farves jo alligevel.

Hilsen Lis

Kommentar
Fra : evigsommer


Dato : 06-04-03 02:12

Okay, det ser jeg. Linket er ok. Men hvad er der så i vejen? Du snakkede om printeropsætning ...

Klaus

Kommentar
Fra : benkvist


Dato : 06-04-03 07:47

Hej

Det kunen måske tyde på at det kun er Klaus's opsætning det er galt med. Jeg ser og printer også linkene uden besvær. Koden er rigtig, og så fremdeles.
Det eneste sted der ellers kunne være tale om at der måske kunne have været noget var i CSS'erne, men så vidt jeg kan se er der ikke opsat nogen speciel PRINT-CSS (hvor man sætte "DISPLAY=NONE" i de enkelte egenskaber/tags som f.eks. <H1>

Men ellers har jeg faktisk ikke nogen idé umiddelbart til hvad det kan være...

Trækkes teksten "sammen" der hvor linket skulle være, eller efterlades der en "tom plads" ?


mvh

BenKvist

Kommentar
Fra : LisBJensen


Dato : 06-04-03 11:03

hej Klaus, jeg kan heller ikke finde andre muligheder.
Når du får al den anden tekst med ud kan det kun være et problem der ligger hos dig selv. Næste gang du starter din browser, så slet alt hvad der måtte være i Cache (Værktøjer / indstillinger/temporære filer). Tjek også lige om javafunktionen må være der
Samme sted fanen advanced Microsoft JIT skal være tjektegn i, de andre to ingen tjektegn)
Når du har gjort det, kan du gå ind på din side og se om det er Ok nu
Hvis ikke det hjælper kan jeg ikke rigtig komme på flere gode ideer.

Lis

Kommentar
Fra : evigsommer


Dato : 06-04-03 12:50

Hej alle!

Lis, jeg har gjort det, du sagde. Hjalp ikke. Så opdagede jeg, at min printer kørte i natural og ikke i sort. Da jeg slog printeren til at printe KUN i sort, kom linkene med. Noget tyder på, at man farvepatron er færdig, da mine links jo er lyseblå og kræver farvepatron. Det må vel i al sin enkelhed være årsagen, ikke?

Mvh.

Klaus

Kommentar
Fra : benkvist


Dato : 06-04-03 15:08

Tja...

Det er liges som det her med at tjekke om stikket sidder i kontakten...

Nu er det så et spørgsmål om hvordan du vil komme af med dine 100 point Du kan jo ikke købe en farvepatron for dem...

mvh

BenKvist

Accepteret svar
Fra : LisBJensen

Modtaget 100 point
Dato : 06-04-03 15:54

hej Klaus.

Det burde koste dine point + ekstra (smil)

Lis

Godkendelse af svar
Fra : evigsommer


Dato : 06-04-03 16:30

Hej alle!

Ja, jeg undskylder mine fjumrerier, som har spildt jeres tid. Til gengæld er jeg i processen blevet klogere - og det er nok også tiltrængt - og I har stiftet bekendtskab med en amatør, som jeg også fra starten sagde, jeg var *S*. Nå, men okay, når jeg har givet de 100 point til Lis, skyldes det, at hun er den, der har svaret flest gange på mine kvaler. Jeg håber, at det er retfærdigt nok. Hvorom alting er, så vil jeg gerne her benytte lejligheden til at sige alle tak for deres hjælp. Hvis og såfremt jeg vender tilbage med et andet problem, lover jeg først at "tjekke om stikket sidder i kontakten".

Mvh.

Klaus               

Kommentar
Fra : LisBJensen


Dato : 06-04-03 16:52

Det er helt OK.
men huske også lige at tjekke dine patroner m.m. *s*
Sig til hvis jeg kan hjælpe dig en anden gang.
Lis

Du har følgende muligheder
Eftersom du ikke er logget ind i systemet, kan du ikke skrive et indlæg til dette spørgsmål.

Hvis du ikke allerede er registreret, kan du gratis blive medlem, ved at trykke på "Bliv medlem" ude i menuen.
Søg
Reklame
Statistik
Spørgsmål : 177360
Tips : 31960
Nyheder : 719565
Indlæg : 6407421
Brugere : 218867

Månedens bedste
Årets bedste
Sidste års bedste