/ Forside/ Teknologi / Multimedie & design / Dreamweaver / Spørgsmål
Login
Glemt dit kodeord?
Brugernavn 

Kodeord  


Reklame
Top 10 brugere
Dreamweaver
#NavnPoint
bentjuul 2364
molokyle 1030
BoJohansen 912
dk 650
ajohansen 520
jakjoe 500
LisBJensen 345
CLAN 336
basil28 320
10  Ishoey 310
Flash Plugin
Fra : HPKristensen
Vist : 253 gange
100 point
Dato : 20-08-04 16:54

Hej,
jeg har en hjemmeside, som jeg har lavet i DW. Men jeg har fået lavet noget Flash på index filen og der ligger en video i mit galleri som også er i Flash, problemet er bare at jeg fandt ud af at man ikke kunne se det der er lavet i Flash ude fra min arb. plads. Det er sandsynligvis nok fordi maskinen jeg sad ved mangler et flash plugin!? Men det jeg så godt kunne tænke mig, var at en lille service meddelelse poppede frem og sagde at det kræver flash plugin at se siden og med et link til hvor man kan downloade et sådant... Hvordan gør jeg lige det? Er der nogle der ved det? Man vil jo gerne være lidt service-minded så alle har mulighed fopr at se siden.
Eller er det her et spørgsmål jeg skal henvende mig med i "flash afdelingen" på Kandu.dk?
MVH HPKristensen
P.S. hjemmesiden hedder www.hannesfoto.dk


 
 
Kommentar
Fra : BoJohansen


Dato : 20-08-04 19:27

Nu vil jeg ikke lige gøre mig sindsygt klog på dette(Er ikke flash udvikler), men hvis du går i Insert-->Media-->Flash og vælger din flash film derfra, så tror jeg da at den generede kode indeholder det der skal til.

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="32" height="32">
<param name="movie" value="/DIN_FLASH.SWF" />
<param name="quality" value="high" />
<embed src="/design_kladde.gif" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="32" height="32"></embed>
</object>

Men det kan da godt være jeg tager fejl?

Kommentar
Fra : HPKristensen


Dato : 20-08-04 20:48

Jeg prøver lige at kigge i code view om mit også ser sådan ud. men lige nu driller min "show code view/ show design view" så jeg prøver lige at spørge hvad jeg skal gøre ved det først og så må jeg lige kigge ind i koderne og se om jeg også har <embed src="/design_kladde.gif" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="32" height="32"></embed>
stående. Men jeg har ellers brugt Insert-->Media-->Flash funktionen....
MVH HPKristensen
Vender lige tilbage...

Kommentar
Fra : HPKristensen


Dato : 20-08-04 20:55

Der står følgende i mine koder -Som jeg måtte kigge i på nettet- for nu kan jeg slet ikke komme ind i "show code view" på min index fil. MEGET anstrengende! Jeg ved ikke lige hvad der sker. Men her er hvordan min kode ser ud, men da jeg sad og så på min hjemmside ude fra mit arbejde, kom der altså ikke noget popup vindue...

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="780" height="280">
<param name="movie" value="../flash/navn_drop.swf">
<param name="quality" value="high">
<embed src="../flash/navn_drop.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="780" height="280"></embed></object>

MVH HPKristensen
Stadig forvirret....

Kommentar
Fra : BoJohansen


Dato : 20-08-04 21:12

http://www.moock.org/webdesign/flash/detection/moockfpi/

Blev lidt nysgerrig på dette, og fandt dette link

Håber det kan bruges

Kommentar
Fra : HPKristensen


Dato : 20-08-04 22:45

Okay... Interessant.... Så ku det være jeg simpelthen bare skulle lave en forside til forsiden hor brugeren så selv kan vælge om han/hun vil se en Flash eller non Flash version....? Hmmmm.... Øv....
Gad vide hvorfor det der Flash detectin kun virker 90-97% af gangene... Mærkeligt.
Nå, men tak i hvert fald... Jeg overvejer at gøre ovennævnte, men venter lige og ser om der kommer en anden løsning op... Hihi.
Tak
HPKristensen

Accepteret svar
Fra : BoJohansen

Modtaget 100 point
Dato : 20-08-04 22:55
Kommentar
Fra : BoJohansen


Dato : 20-08-04 23:02
Godkendelse af svar
Fra : HPKristensen


Dato : 21-08-04 09:55

OK. Det må jeg prøve. Jeg kan bare ikke komme ind i koderne i DW. Så jeg får lidt svært ved at implementere det i min index fil. Det er røv irriterende. Før drillede det bare, men nu kan jeg slet ikke komme ind i "Show Code View" på indexfilen. Nå, men jeg må jo se hvad jeg kan gøre.
Tak for svarene i hvert fald!    
HPKristensen            

Kommentar
Fra : HPKristensen


Dato : 21-08-04 14:01

Hej igen,
nu har jeg downloadet det der flash detectin kit. Men der er vist noget galt. Nu er jeg så kløgtig at jeg ikke tog en backup af min gamle indexfil før jeg prøevde at indsætte denne her smarte flashdetection behaviour.
Problemet er at når jeg via Preview in IE explorer i DW kigger på min indexfil nu, så springer den over i et "siden kan ikke vises" billede når flash filen er kørt færdig. (Se evt på hannesfoto.dk Det er når bogstaverne i mit navn er kørt på plads den springer over i "siden kan ikke vises") Jeg tør ikke loade den op på serveren for at teste om den også gør det på nettet eller om det kun er på min computer, for jeg fik jo ikke lavet en backup...
Hvad gør jeg nu?
Jeg har prøvet at kopiere kilden fra nettet, men den for ikke top og bund framen med, så jeg kan ikke engang lave en backup på den måde... Og jeg kan ikke finde ud af at lave en ny bund og top for jeg kan sku ikke huske hvordan man arbejder med frames... Jeg er vist helt på herrens mark nu...
Måske har jeg ikke lagt de der flash detection mapper rigtigt? Men det er bare mærkeligt, for den burde jo ikke detecte noget hos mig, for jeg HAR jo flash plugin....
Åh, gud, hvad søren har jeg lavet.... :-/
MVH HPKristensen
-Nu med grå hår

Kommentar
Fra : HPKristensen


Dato : 21-08-04 14:06

Hej igen,
nu har jeg downloadet det der flash detectin kit. Men der er vist noget galt. Nu er jeg SÅ kløgtig at jeg IKKE tog en backup af min gamle indexfil før jeg prøevde at indsætte denne her smarte flashdetection behaviour.
Problemet er at når jeg via Preview in IE explorer i DW kigger på min indexfil nu, så springer den over i et "siden kan ikke vises" billede når flash filen er kørt færdig. (Se evt på hannesfoto.dk Det er når bogstaverne i mit navn er kørt på plads den springer over i "siden kan ikke vises") Jeg tør ikke loade den op på serveren for at teste om den også gør det på nettet eller om det kun er på min computer, for jeg fik jo ikke lavet en backup...
Hvad gør jeg nu?
Jeg har prøvet at kopiere kilden fra nettet, men den får ikke top og bund framen med, så jeg kan ikke engang lave en backup på den måde... Og jeg kan ikke finde ud af at lave en ny bund og top for jeg kan sku ikke huske hvordan man arbejder med frames... Jeg er vist helt på herrens mark nu...
Måske har jeg ikke lagt de der flash detection mapper rigtigt? Men det er bare mærkeligt, for den burde jo ikke detecte noget hos mig, for jeg HAR jo flash plugin....
Åh, gud, hvad søren har jeg lavet.... :-/
MVH HPKristensen
-Nu med grå hår

Kommentar
Fra : BoJohansen


Dato : 21-08-04 14:13

Her kildekoden til din index fil som ligger online :

<html>
<head>
<title>Fotograf Hanne Paludan Kristensen</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<script language="JavaScript">
<!--

function MM_preloadImages() { //v3.0
var d=document; if(d.images){ if(!d.MM_p) d.MM_p=new Array();
var i,j=d.MM_p.length,a=MM_preloadImages.arguments; for(i=0; i<a.length; i++)
if (a[i].indexOf("#")!=0){ d.MM_p[j]=new Image; d.MM_p[j++].src=a[i];}}
}

function MM_swapImgRestore() { //v3.0
var i,x,a=document.MM_sr; for(i=0;a&&i<a.length&&(x=a[i])&&x.oSrc;i++) x.src=x.oSrc;
}

function MM_findObj(n, d) { //v4.0
var p,i,x; if(!d) d=document; if((p=n.indexOf("?"))>0&&parent.frames.length) {
d=parent.frames[n.substring(p+1)].document; n=n.substring(0,p);}
if(!(x=d[n])&&d.all) x=d.all[n]; for (i=0;!x&&i<d.forms.length;i++) x=d.forms[i][n];
for(i=0;!x&&d.layers&&i<d.layers.length;i++) x=MM_findObj(n,d.layers[i].document);
if(!x && document.getElementById) x=document.getElementById(n); return x;
}

function MM_swapImage() { //v3.0
var i,j=0,x,a=MM_swapImage.arguments; document.MM_sr=new Array; for(i=0;i<(a.length-2);i+=3)
if ((x=MM_findObj(a[i]))!=null){document.MM_sr[j++]=x; if(!x.oSrc) x.oSrc=x.src; x.src=a[i+2];}
}
//-->
</script>
</head>

<body bgcolor="#6699cc" text="#000000" onLoad="MM_preloadImages('galleri01.jpg','gaest01.jpg','kontakt01.jpg','fotografen01.jpg')">
<div id="Layer3" style="position:absolute; left:411px; top:285px; width:375px; height:100px; z-index:3">
<table width="375" border="0" cellspacing="0" cellpadding="0" height="100">
<tr>
<td height="100" width="75"><a href="../galleri.htm" target="mainFrame"><img src="galleri00.jpg" width="75" height="100" name="Image1" onMouseOut="MM_swapImgRestore()" onMouseOver="MM_swapImage('Image1','','galleri01.jpg',1)" border="0" alt="Se nogle af mine billeder her"></a></td>
<td width="25" height="100">&nbsp;</td>
<td height="100" width="75"><a href="http://www.hostedstuff.com/services/chatboard/?id=2507" target="mainFrame"><img src="gaest00.jpg" width="75" height="100" name="Image2" onMouseOut="MM_swapImgRestore()" onMouseOver="MM_swapImage('Image2','','gaest01.jpg',1)" alt="Skriv ris og ros til mine billeder og /eller hjemmesiden" border="0"></a></td>
<td width="25" height="100">&nbsp;</td>
<td height="100" width="75"><a href="../kontakt.htm" target="mainFrame"><img src="kontakt00.jpg" width="75" height="100" name="Image3" onMouseOut="MM_swapImgRestore()" onMouseOver="MM_swapImage('Image3','','kontakt01.jpg',1)" alt="Lidt om mig og hvordan du kontakter mig" border="0"></a></td>
<td width="25" height="100">&nbsp;</td>
<td height="100" width="75"><a href="../fotografen.htm" target="mainFrame"><img src="fotografen00.jpg" width="75" height="100" name="Image4" onMouseOut="MM_swapImgRestore()" onMouseOver="MM_swapImage('Image4','','fotografen01.jpg',1)" border="0"></a></td>
</tr>
</table>
</div>
<div id="Layer2" style="position:absolute; left:-3px; top:1px; width:781px; height:284px; z-index:2">
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="780" height="280">
<param name="movie" value="../flash/navn_drop.swf">
<param name="quality" value="high">
<embed src="../flash/navn_drop.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="780" height="280"></embed></object>
</div>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
</body>
</html>

Nu har jeg ikke selv arbejdet med Flash Detection Kit, men læs Read Me filen godt og grundigt igennem og prøv igen.

Kommentar
Fra : BoJohansen


Dato : 21-08-04 14:22

Jeg gør ofte det det at jeg laver(kopiere) mine problem sider over i en Test mappe, og her fra tester og roder rundt i koden.

Mange gange ved sider med meget kode, er det nemmere at lave en helt ny test_side som kun indeholder det kode som giver problemer, rette det til og så bare tilføje det til original siden når det er ok, I code view selvfølgelig.

Kommentar
Fra : HPKristensen


Dato : 21-08-04 20:27

Jeg ved godt hvordan kildekoden ligger på nettet og jeg har også kopieret den, men jeg får stadig ikke top- og bundframe med.... Det er kun mainframen det der står ovenover... Og når jeg kopierer ovenstående ind i en test-side i DW ser det meget mærkeligt ud. Billederne er der ikke osv.

Jeg har læst den der read me, og de står at jeg skal kopierer alt det der fra detectin kitttet ud på serveren og det har jeg gjort. Kan du se min hjemmeside, helt som den skal ses, fra din computer?

Kommentar
Fra : BoJohansen


Dato : 22-08-04 14:29

Selve index, default koden ser sådant ud :

<html>
<head>
<title>Hannes foto</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<script language="JavaScript">
<!--
function MM_reloadPage(init) { //reloads the window if Nav4 resized
if (init==true) with (navigator) {if ((appName=="Netscape")&&(parseInt(appVersion)==4)) {
document.MM_pgW=innerWidth; document.MM_pgH=innerHeight; onresize=MM_reloadPage; }}
else if (innerWidth!=document.MM_pgW || innerHeight!=document.MM_pgH) location.reload();
}
MM_reloadPage(true);
// -->
</script>
</head>
<frameset rows="80,*" frameborder="NO" border="0" framespacing="0">
<frame name="topFrame" scrolling="NO" noresize src="design/top.htm" >
<frameset rows="*,80" frameborder="NO" border="0" framespacing="0">
<frame name="mainFrame" src="design/forside.htm" scrolling="YES">
<frame name="bottomFrame" scrolling="NO" noresize src="design/bund.htm">
</frameset>
</frameset>
<noframes>
<body bgcolor="#FFFFFF" text="#000000">
</body>
</noframes>
</html>

Så har du jo de sider som udgør indholdet af dine frames :
design/top.htm
design/forside.htm
design/bund.htm
Så kan du jo bare kalde de sider for at kopier koden.

Dine billeder osv. vises ikke, medmindre at du gemmer den nye side i en tilsvarende mappe som original siden, ellers bliver linkene til dine billeder jo forkert.
Dette skyldes at du linker relativt til dokumentet [fotografen00.jpg] og ikke web roden [/design/fotografen00.jpg]

Kommentar
Fra : BoJohansen


Dato : 22-08-04 14:31

Og ja, jeg ser siden som den skal ses

Du har følgende muligheder
Eftersom du ikke er logget ind i systemet, kan du ikke skrive et indlæg til dette spørgsmål.

Hvis du ikke allerede er registreret, kan du gratis blive medlem, ved at trykke på "Bliv medlem" ude i menuen.
Søg
Reklame
Statistik
Spørgsmål : 173636
Tips : 31664
Nyheder : 719565
Indlæg : 6383613
Brugere : 218258

Månedens bedste
Årets bedste
Sidste års bedste