/ Forside/ Teknologi / Administrative / MS-Office / Spørgsmål
Login
Glemt dit kodeord?
Brugernavn 

Kodeord  


Reklame
Top 10 brugere
MS-Office
#NavnPoint
sion 18609
refi 14474
Klaudi 8489
Rosco40 5695
berpox 5456
dk 5398
Benjamin... 4870
webnoob 4747
o.v.n. 4637
10  EXTERMINA.. 4373
Cprnr. afkodning til Excel
Fra : FlemmingU
Vist : 1077 gange
120 point
Dato : 16-06-04 19:16

Er der nogen som kan hjælpe mig med en beregningskode til Excel;

Jeg har cprnr på en lang række personer - og brug for, at løsningen automatisk kan beregne om personen er mand eller kvinde.

Er der nogen som har den kode jeg skal bruge, for at dette automatisk kan regnes ?

/Flemming Udbjørg

 
 
Kommentar
Fra : Better_Performance


Dato : 16-06-04 19:20

Det er vel bare at dele dem op i lige og ulige.

Mænd = Ulige nr.
Kvinder = Lige nr.

Kommentar
Fra : ostemanden


Dato : 16-06-04 19:27

ja... de fire sidste cifre i dit personnummer afgører om du er mand eller kvinde, alt efter om det er et lige eller ulige tal....

Hvis det er lige - fx. 1234, er det en kvinde
Hvis det er ulige, fx. 1235 er det en kvinde

Måden du kan tjekke det på er fx. at bruge modulus funktionen, og fx. se om feltets værdi % 2 = 0 eller 1. Er det 0, er det et lige tal, ergo kvinde. Er det 1, er det et ulige tal og ergo en mand.

Kommentar
Fra : FlemmingU


Dato : 16-06-04 19:28

Tak til Better_Performance. Nu ved jeg så ikke hvordan jeg får Excel til at sorterere en kolonne med cprnr. i lige og ulige.

Men det jeg søger, er er løsning, hvor Excel selv beregner kønnet.

/Flemming

Kommentar
Fra : FlemmingU


Dato : 16-06-04 19:30

Hej Ostemanden.

modulus funktionen ? - hjælp mig lige med at finde den. Mine indtastede cprnr. ser såles ud; 010190-1234

/Flemming

Kommentar
Fra : Soenne


Dato : 16-06-04 19:36

>Ostemanden. Jeg håber da det er omvendt, at det er kønnet der afgør de sidste 4 cifre. Øhh er vi iøvrigt kvinder alle sammen

Kommentar
Fra : ostemanden


Dato : 16-06-04 19:40

argh... jaja, sry sry... min fejl!

Kommentar
Fra : ostemanden


Dato : 16-06-04 19:45

og jeg kender ikke til excel desværre flemming... men ved at modulus er normalt %-tegnet. Prøv at skriv =2%3 i et felt og se om den skriver et 1 tal...

Kommentar
Fra : FlemmingU


Dato : 16-06-04 19:51

Næhhhhhhhhh. =2%3 i en celle giver en fejlmeddelelse hos mig.

Accepteret svar
Fra : emesen

Modtaget 130 point
Dato : 16-06-04 19:52

Det er noget i denne stil men jeg har fejl i formlen.
=HVIS(HØJRE(A1;1)*ELLER(1;3;5;7;9);"mand";"Kvinde")
hvis første ciffer fra højre er enten 1-3-5-7-9 resutat mand ellers kvinde
min fejl er omkring >>*ELLER<<
Emesen.

Kommentar
Fra : ostemanden


Dato : 16-06-04 20:02

Prøv så at skrive =odulus(3,2)

Kommentar
Fra : ostemanden


Dato : 16-06-04 20:02

=Modulus(3,2) self...

Kommentar
Fra : FlemmingU


Dato : 16-06-04 20:09

=Modulus(3,2) virker heller ikke hos mig.

Kommentar
Fra : FlemmingU


Dato : 16-06-04 20:44

Jeg fandt løsningen, efter at have prøvet mig frem med nogle af tipsene ovenfor - og have parret dem med Excel hjælp.

Formlen ser således ud: =HVIS(ER.LIGE(HØJRE(D18));"kvinde";"mand")

Tak for indsatsen

Kommentar
Fra : emesen


Dato : 16-06-04 20:48

Nåe ja der er jo også funktionen "er.lige"
Det behøver ikke altid at være indviklet.
Emesen.

Godkendelse af svar
Fra : FlemmingU


Dato : 16-06-04 20:58

Tak for svaret emesen. Det var det, der satte mig på sporet.
/Flemming
                        

Kommentar
Fra : emesen


Dato : 16-06-04 21:01

Selv tak - det er meget sjovt med lidt hjernevridning.

Kommentar
Fra : emesen


Dato : 16-06-04 21:11

En henvisning til snak om personnummerkontroludregning.
http://www.kandu.dk/dk/spg/39668
Rul ned til den store forklaring.


Du har følgende muligheder
Eftersom du ikke er logget ind i systemet, kan du ikke skrive et indlæg til dette spørgsmål.

Hvis du ikke allerede er registreret, kan du gratis blive medlem, ved at trykke på "Bliv medlem" ude i menuen.
Søg
Reklame
Statistik
Spørgsmål : 173642
Tips : 31664
Nyheder : 719565
Indlæg : 6383651
Brugere : 218258

Månedens bedste
Årets bedste
Sidste års bedste