/ Forside/ Teknologi / Udvikling / HTML / Spørgsmål
Login
Glemt dit kodeord?
Brugernavn 

Kodeord  


Reklame
Top 10 brugere
HTML
#NavnPoint
molokyle 11184
Klaudi 5306
bentjuul 3377
severino 2040
smorch 1950
strarup 1525
natmaden 1396
scootergr.. 1320
e.c 1150
10  miritdk 1110
submit knap virker ikke
Fra : soester
Vist : 220 gange
20 point
Dato : 15-09-03 14:45

Jeg er ved at lave en formular i go live 6 som ser ud som følgende:

<form class="tekst" action="mailto:lenapoulsen@yahoo.com" method="post" name="tilmelding" onsubmit="CSAction(new Array(/*CMP*/'BB8B675E0'));" cssubm="BB8B675E0">
                                    <div align="left">
                                       <span class="overskrifter">Få tilsendt girokort til medlemskab<br>
                                          <br>
                                       </span>
                                       <table width="280" border="0" cellspacing="0" cellpadding="0">
                                          <tr>
                                             <td width="90"><span class="tekst">Fornavn</span></td>
                                             <td width="195"><input type="text" name="Fornavn" size="29" border="0"></td>
                                          </tr>
                                          <tr>
                                             <td width="90"><span class="tekst">Efternavn</span></td>
                                             <td width="195"><input type="text" name="Efternavn" size="29" border="0"></td>
                                          </tr>
                                          <tr>
                                             <td width="90"><span class="tekst">Adresse</span></td>
                                             <td width="195"><input type="text" name="Adresse" size="29" border="0"></td>
                                          </tr>
                                          <tr>
                                             <td width="90"><span class="tekst">Postnr.</span> <input type="text" name="Postnr." size="5" maxlength="5" border="0"></td>
                                             <td width="195">
                                                <div align="left">
                                                   <span class="tekst">By</span> <input type="text" name="By" size="25" border="0"></div>
                                             </td>
                                          </tr>
                                          <tr>
                                             <td width="90"><span class="tekst">Telefon</span></td>
                                             <td width="195"><input type="text" name="Telefon" size="29" border="0"></td>
                                          </tr>
                                          <tr>
                                             <td width="90"><span class="tekst">Mobiltlf.</span></td>
                                             <td width="195"><input type="text" name="Mobiltlf." size="29" border="0"></td>
                                          </tr>
                                          <tr height="21">
                                             <td width="90" height="21"><span class="tekst">E-mail</span></td>
                                             <td width="195" height="21"><input type="text" name="textfieldName" size="29" border="0"></td>
                                          </tr>
                                       </table>
                                        <span class="tekst"><b> <input class="tekst" type="submit" name="" value="SEND" border="0"> <input class="tekst" type="reset" value="RYD" border="0"></b></span></div>
                                 </form>

Rydknappen virker efter hensigten men sendknappen virker ikke.

Hvad gør jeg galt?



 
 
Kommentar
Fra : ameq_


Dato : 15-09-03 14:50

prøv at give den et navn ?? ved ikke om det virker...!

Kommentar
Fra : ameq_


Dato : 15-09-03 14:50

prøv at give den et navn ?? ved ikke om det virker...!

Kommentar
Fra : ameq_


Dato : 15-09-03 14:50

prøv at give den et navn ?? ved ikke om det virker...!

Kommentar
Fra : ameq_


Dato : 15-09-03 14:53

ikke for at spamme, sorry...
Men virker det at lave en action til en mail?

Kommentar
Fra : soester


Dato : 15-09-03 14:53

AMEQ
Hvad mener du med efternavn????


Kommentar
Fra : smorch


Dato : 15-09-03 14:54

Fjern :

onsubmit="CSAction(new Array(/*CMP*/'BB8B675E0'));" cssubm="BB8B675E0"

Mvh

sMorch

Kommentar
Fra : soester


Dato : 15-09-03 15:08

Har nu prøvet at fjerne

onsubmit="CSAction(new Array(/*CMP*/'BB8B675E0'));" cssubm="BB8B675E0"

men det virker heller ikke.



Kommentar
Fra : ameq_


Dato : 15-09-03 15:11

soester
Nope men din submit knap har ikke noget navn (name="" i din kode)
Men tror ikke det er det...

Kommentar
Fra : smorch


Dato : 15-09-03 15:12

Har du modtaget en mail fra mig ?
Den er sendt fra en kopi af din kode minus onsubmit halløjet.

Mvh

sMorch

Kommentar
Fra : ameq_


Dato : 15-09-03 15:16

soester, jeg tror ikke lige det virker det med at sende en mail sådan???
Ved det ikke men har du prøvet det før?

Men hvor ligger din webserver?

Kommentar
Fra : soester


Dato : 15-09-03 15:17

hej AMEQ

Har nu givet den navnet SEND men det ændrer ikke noget.

er det måske igen en af de dumme ting der er anderledes ved en MAC fremfor en PC'er?

Kommentar
Fra : smorch


Dato : 15-09-03 15:18

Jo - det virker !

sMorch

Kommentar
Fra : soester


Dato : 15-09-03 15:18

hej AMEQ

Har nu givet den navnet SEND men det ændrer ikke noget. Hver gang jeg prøver at udfylde og sende en formular står
der at der opstod en tilslutningsfejl.

er det måske igen en af de dumme ting der er anderledes ved en MAC fremfor en PC'er?

Kommentar
Fra : soester


Dato : 15-09-03 15:18

hej AMEQ

Har nu givet den navnet SEND men det ændrer ikke noget. Hver gang jeg prøver at udfylde og sende en formular står
der at der opstod en tilslutningsfejl.

er det måske igen en af de dumme ting der er anderledes ved en MAC fremfor en PC'er?

Kommentar
Fra : soester


Dato : 15-09-03 15:21

hej sMorch

Har modtaget en mail fra dig

men forstår så ikke hvorfor koden ikke virker hos mig.



Kommentar
Fra : ameq_


Dato : 15-09-03 15:23

Måske, men den tid jeg har skrivet hjemmesider har jeg aldrig set den måde at sende mails på =) Den skriver godt nok et eller andet, når jeg trykker submit men ja ja ok til dig knap =) men kan ikke se hvordan det form du har lavet kan overholde en nomal mail, ved ikke lige hvordan den skal få info fra fælderne ind i mail og hvad den skal sende fra? For som det ser ud har du ikke nolge SMTP server (SMTP er en server som sender mails), men jeg ville finde et ASP eller PHP script og gøre det med... hvis du kan det på din webserver??!?!?

Kommentar
Fra : smorch


Dato : 15-09-03 16:25

http://www.morch.dk/mailtest.htm

Når man så trykker på SEND vil der blive spurgt om man vil sende som mail, hvilket manså skal svar ok til - det er så via ens eget mailprogram mailen bliver sendt næste gang der er postlevering.

Hvis ikke man har en mailkonto sat op på maskinen, virker det ikke.

sMorch

Kommentar
Fra : ameq_


Dato : 15-09-03 16:30

Så det er vil et svar, så jeg ville kigge efter noget der er gratis eller installer noget din webserver... Ved stofanet har sådan et cgi script hvor du lave en mail form...

Kommentar
Fra : smorch


Dato : 15-09-03 16:52

De fleste udbydere har en eller anden form for script man kan sende til - se i din udbyders support sektion.
Det her virker i hvert fald - hvis altså folk sidder ved deres egne pc'er med en korrekt opsat mailkonto.

Mvh

sMorch

Kommentar
Fra : ameq_


Dato : 16-09-03 07:56

men sMorch kan man også alt tid gå ud fra det?, på min private pc har jeg har ikke sat en op =), jeg ville nok kigge et fri script =)

Kommentar
Fra : smorch


Dato : 16-09-03 08:48

Nej - derfor læs første linie igen.




Kommentar
Fra : soester


Dato : 16-09-03 10:29

Hej Smoch

Jeg har nu prøvet linket

ttp://www.morch.dk/mailtest.htm

af og den kan jeg heller ikke få til at køre så jeg er blevet enig med mig selv om at det må være noget med serveren eller fordi jeg arbejder på en mac. Så jeg må undvære formularen.

Soester

Kommentar
Fra : MadsRG


Dato : 18-11-03 03:22

Hej Soester!

Kig her:
http://www.w3.org/TR/REC-html40/interact/forms.html

Lidt nede på siden står der:

action = uri [CT]
This attribute specifies a form processing agent. User agent behavior for a value other than an HTTP URI is undefined.

Dvs. at det ikke er så smart at lave en "mailto:" i action, da det er helt op til de forskellige browsere hvordan de vil reagere, det er nemlig ikke en del af standarden! Så jeg vil råde dig til ikke at have "mailto:" i action. Håber det hjalp!

Du har følgende muligheder
Dette spørgsmål er blevet annulleret, det er derfor ikke muligt for at tilføje flere kommentarer.
Søg
Reklame
Statistik
Spørgsmål : 176969
Tips : 31936
Nyheder : 719565
Indlæg : 6404898
Brugere : 218803

Månedens bedste
Årets bedste
Sidste års bedste