/ Forside/ Teknologi / Administrative / MS-Office / Spørgsmål
Login
Glemt dit kodeord?
Brugernavn 

Kodeord  


Reklame
Top 10 brugere
MS-Office
#NavnPoint
sion 18609
refi 14474
Klaudi 8489
Rosco40 5695
berpox 5456
dk 5398
webnoob 4919
Benjamin... 4870
o.v.n. 4637
10  EXTERMINA.. 4373
Visning/beregning af tid i Excel 365
Fra : yuri71
Vist : 166 gange
120 point
Dato : 22-09-21 09:59

Jeg bruger et regneark til registrering af arbejdstid i Excel 365. Det er et regneark jeg en gang har fundet på nettet.

Det er helt simpelt. Man taster sin faste normtid ind for hver arbejdsdag i en tabel. I skemaet indtaster man sin komme og gå tid hver dag. I kolonne L vises flex saldo.

Men jeg har opdaget at hvis flex saldo rammer hele timer, så vises 7 timer som 6 timer og 60 minutter, og hvis man registrerer videre de næste dage, så "snyder" den for en hel time.

I kolonne M beregnes saldoen også, men vises som et kommatal. 7,0 vises i kolonne L som 6 timer og 60 minutter. 8,0 vises som 7 timer og 60 minutter.

Jeg kan ikke gennemskue formlerne, men har prøvet at ændre tidsformatet i kolonne L til forskellige tidsformater uden held.

Da jeg ikke kan se det er muligt at vedhæfte en fil sætter jeg formlerne ind der er brugt i hhv. kolonne M og L for række 29.

Formel i kolonne M:
Kode
=HVIS(D29="LF";M28;(M28+(F29-E29+H29-G29+J29-I29-VOPSLAG(B29;$D$7:$J$9;3;FALSK)+VOPSLAG(B29;$D$7:$J$9;2;FALSK))*24))-K29


Formel i kolonne L:
Kode
=HVIS(L28="";"";HVIS(IDAG()<C29;"";SAMMENKÆDE(HVIS(M29<0;"-";"+");ABS(AFKORT(M29;0));" timer ";TEKST(HVIS(M29<0;HVIS((60-REST(M29;1)*60)=60;0;HVIS(M29<0;60-REST(M29;1)*60;REST(M29;1)*60));REST(M29;1)*60);"00");" min")))



 
 
Kommentar
Fra : Thomas_Mygind


Dato : 22-09-21 19:33

Problemet ligger i ABS - altså den absolutte del - som nok smidder dine minutter væk.

Du kan evt. lægge 1 sekund til i dine formler så runder den nok rigtig af.

Kommentar
Fra : Bille1948


Dato : 22-09-21 19:45

I stedet for at bruge en kolonne til timer og en til minutter, så lav det om til én kolonne, så regner Excel rigtigt, og du er ude over en anden brugers - fejlagtige - formel defenition.

Kommentar
Fra : Eyvind


Dato : 23-09-21 12:00

Hvis du vil vise noget her på Kandu dk kan du bruge dette:
https://da.imgbb.com/ gratis billede hosting / billede opload
Og så lægge linket her i spørgsmålet
eks. https://ibb.co/vPjGsSf

Kommentar
Fra : yuri71


Dato : 24-09-21 13:00

Hej

Så har jeg lavet et skærmdump af regnearket hvis det kan hjælpe.

https://ibb.co/YkVB8Dk


Kommentar
Fra : Bille1948


Dato : 24-09-21 13:17

Det hjælper absolut intet. Der kan man jo ikke se formler eller rette.

Læg selve regnearket derind.

Kommentar
Fra : yuri71


Dato : 24-09-21 14:32

Men det er da kun billeder man kan uploade. Hvis jeg prøver med Excel-filen siger den forkert format. Der står at man kan uploade disse formater: JPG PNG BMP GIF TIF WEBP HEIC PDF

Kommentar
Fra : Bille1948


Dato : 24-09-21 14:48

Så duer det ikke.

Kommentar
Fra : for_lækker


Dato : 24-09-21 17:35

Lav et skærmdump af din excel formel

Kommentar
Fra : Bille1948


Dato : 24-09-21 17:47

Det har vi fået.

Kommentar
Fra : for_lækker


Dato : 24-09-21 19:12

Citat
Kommentar
Fra :Bille1948

Dato : 24-09-21 13:17
Det hjælper absolut intet. Der kan man jo ikke se formler eller rette.

Læg selve regnearket derind.




Kommentar
Fra : Bille1948


Dato : 24-09-21 20:01



Kommentar
Fra : yuri71


Dato : 29-09-21 16:05

@Thomas Mygind kan du forklare lidt mere hvordan man skulle lægge 1 sekund på formlerne. Og hvilke formler du mener. Jeg har tidligere lagt formler fra to forskellige saldokolonner ind i tråden.

Jeg har længere oppe i tråden lagt link til et skærmdump af selve regnearket. så man kan se hvordan det ser ud.

Kommentar
Fra : Thomas_Mygind


Dato : 29-09-21 22:08

Tror det er meget nemmere at starte helt forfra - på den simple måde !

Prøv at skrive to tidspunkter i to celler f.eks. 17:05 i celle C3. og 08:08 i celle C2. Prøv at trække de 2 celler fra hinanden i celle C5 - så burde der stå svaret: 08:53

Hvis du vil undgå mærkelige tegn, så kan du indsætte en "IF"-sætning så skriv sådan her i din udregning i C6:
=IF(C5;0;C5)
På dansk betyder det at hvis man ikkeindtaster noget i C2 eller C3 - så bliver tallet "0" i C6 - ellers regner den forskellen ud i C6.


Du har følgende muligheder
Eftersom du ikke er logget ind i systemet, kan du ikke skrive et indlæg til dette spørgsmål.

Hvis du ikke allerede er registreret, kan du gratis blive medlem, ved at trykke på "Bliv medlem" ude i menuen.
Søg
Reklame
Statistik
Spørgsmål : 176442
Tips : 31896
Nyheder : 719565
Indlæg : 6401659
Brugere : 218700

Månedens bedste
Årets bedste
Sidste års bedste