/ Forside/ Teknologi / Operativsystemer / MS Windows / Spørgsmål
Login
Glemt dit kodeord?
Brugernavn 

Kodeord  


Reklame
Top 10 brugere
MS Windows
#NavnPoint
Klaudi 69375
o.v.n. 67550
refi 58409
Manse9933 45149
tedd 44737
molokyle 40677
miritdk 38357
briani 27239
BjarneD 26414
10  pallebhan.. 24310
Windows Powershell
Fra : Soren_Steen_Nielsen
Vist : 247 gange
200 point
Dato : 23-06-15 21:40

Hej. Jeg har et problem med Powershell i Windows 7 Home Premium. Jeg har en Raspberry Pi II og har fået en Windows 10 IoT til den, og har installeret den. Men for overhovedet at kunne komme i gang med at bruge den skal man konfigurere den via netværket med Powershell fra en PC.

Ifølge vejledningen fra Microsoft skal man starte Powershell som administrator, og det gør jeg. Herefter skal man skrive:

net start WinRM

- det går fint.

Set-Item WSMan:\localhost\Client\TrustedHosts -value <machine-name or IP Adress>

- Her opstår problemerne. Jeg erstatter naturligvis det i trekantparanteserne men min Raspberry Pi's aktuelle IP-adresse. Men den siger "Adgang nægtet".

Andre steder på nettet har jeg læst mig til at man kan skrive "cd WSMan:", og derefter "cd localhost" fuldstændigt som man gjore i gamle dage når man kiggede efter sine filer i DOS. Og det går fint indtil man skriver cd Client, så er adgang nægtet igen. Står man i "WSMan:\localhost" og skriver dir så er adgang nægtet igen. Men skriver man dir mens man er i "WSMan:\" så kan man godt se "localhost".

-Og jeg har konstateret at Powershell rent faktisk er startet med administratorrettigheder, og jeg har prøvet med to forskellige maskiner.

Hvad kan der være galt? Hvordan løser jeg problemet?

 
 
Kommentar
Fra : EXTERMINATOR


Dato : 24-06-15 02:47

Bare lige for at være sikker:
Når du skriver trekanter, så er det tegnene større end (>) og mindre end (<) du mener, ikke også.
Og du husker også at fjerne de to tegn?
Så hvis din RP har ip adressen 172.16.15.14 så skriver du:
Kode
Set-Item WSMan:\localhost\Client\TrustedHosts -Value 172.16.15.14


Kommentar
Fra : Soren_Steen_Nielsen


Dato : 24-06-15 20:59

Nej selvføgelig har jeg ikke skrevet trekantparanteserne med. Jeg har skrevet kommandoen helt som du selv skriver, dog er IP-adressen en anden hos mig.


Du har følgende muligheder
Dette spørgsmål er blevet annulleret, det er derfor ikke muligt for at tilføje flere kommentarer.
Søg
Reklame
Statistik
Spørgsmål : 173636
Tips : 31664
Nyheder : 719565
Indlæg : 6383610
Brugere : 218258

Månedens bedste
Årets bedste
Sidste års bedste