/ Forside/ Teknologi / Administrative / MS-Office / Spørgsmål
Login
Glemt dit kodeord?
Brugernavn 

Kodeord  


Reklame
Top 10 brugere
MS-Office
#NavnPoint
sion 18609
refi 14474
Klaudi 8489
Rosco40 5695
berpox 5456
dk 5398
Benjamin... 4870
webnoob 4747
o.v.n. 4637
10  EXTERMINA.. 4373
SLÅ.OP i et tekstfelt
Fra : drdegn
Vist : 386 gange
50 point
Dato : 17-10-07 12:47

Række 1: A B C D
Række 2: x y, z z q

Det er let nok at slå 'x' op i række 2 med svaret 'A'
Men hvad hvis nogle felter indeholder flere parametre som f.eks. feltet med 'y, z':
Hvordan slår man 'z' op i række 2, for at få svaret (fra række 1): "B, C".

 
 
Kommentar
Fra : drdegn


Dato : 17-10-07 12:50

[Felterne] bør se således ud:
Række 1: [A] [B] [C] [D]
Række 2: [x] [y, z] [z] [q]

Accepteret svar
Fra : sion

Modtaget 60 point
Dato : 17-10-07 13:18

Jeg regner med, at dine værdier står i celleområdet A1:D2.

I G1 skrives den værdi, du søger efter (i dit spørgsmål "z").

I række 3 skrives denne formel (træk til højre fra A3): =HVIS(ER.FEJL(SØG($G$1;A2));"";A1)

I A4 skrives: =HVIS(A3="";"";A3)

I resten af række 4 skrives (træk til højre fra B4): =HVIS(B3="";A4;HVIS(A4="";B3;A4&", "&B3))

Dit resultat beregnes af denne formel (som du kan skrive i en hvilken som helst tom celle): =INDIREKTE(ADRESSE(4;TÆLV(4:4))) *bemærk at 4-tallerne refererer til række 4, og at formlen skal ændres, hvis du flytter dine beregninger.

Svaret ligner meget det, jeg gav til dit andet spørgsmål i dag

Simon

Godkendelse af svar
Fra : drdegn


Dato : 17-10-07 14:28

Tak for svaret sion. Det havde jeg aldrig gættet selv.

Kommentar
Fra : sion


Dato : 17-10-07 14:37

Jeg kan anbefale, at man studerer de enkelte funktioner i de samlede funktioner, så man kan forstå, hvad der sker. Når man har forståelsen, behøver man ikke gætte.

Eksempelvis er nedenstående del-funktion SAND, hvis den eftersøgte værdi ikke findes i en tekststreng:

=ER.FEJL(SØG([søgestreng];[tekststreng]))

Hvis dette indsættes i en HVIS-funktion { =HVIS(ER.FEJL(SØG($G$1;A2));"";A1) }, kan vi finde ud af, hvornår den eftersøgte værdi findes... Super smart!

I Excel handler det om at kende de enkelte funktioners virkemåde, og om at have fantasi til at kombinere funktionerne. Og husk, at det altid er en god idé at have en masse mellemregninger i flere kolonner eller rækker.

Simon

Du har følgende muligheder
Eftersom du ikke er logget ind i systemet, kan du ikke skrive et indlæg til dette spørgsmål.

Hvis du ikke allerede er registreret, kan du gratis blive medlem, ved at trykke på "Bliv medlem" ude i menuen.
Søg
Reklame
Statistik
Spørgsmål : 173642
Tips : 31664
Nyheder : 719565
Indlæg : 6383651
Brugere : 218258

Månedens bedste
Årets bedste
Sidste års bedste