/ Forside/ Teknologi / Administrative / MS-Office / Spørgsmål
Login
Glemt dit kodeord?
Brugernavn 

Kodeord  


Reklame
Top 10 brugere
MS-Office
#NavnPoint
sion 18609
refi 14474
Klaudi 8489
Rosco40 5695
berpox 5456
dk 5398
Benjamin... 4870
webnoob 4747
o.v.n. 4637
10  EXTERMINA.. 4373
SLÅ.OP med EXCEL
Fra : drdegn
Vist : 570 gange
20 point
Dato : 16-10-07 18:36

A B C
1 s v d
2 g k d
3 e h k
4 s r h
5 g e d

Hvis jeg slår "e" op i kolonne A med kolonne C som resultat fås: k
Men hvad hvis jeg ønsker at slå "s" op i kolonne A for at få resultatet "d, h" fra kolonne C, hvordan gør man det med SLÅ.OP funktionen eller en anden funktion?


 
 
Accepteret svar
Fra : sion

Modtaget 20 point
Dato : 17-10-07 11:27

Du kan ikke bruge SLÅ.OP eller LOPSLAG, fordi de kun kan returnere én værdi. I stedet kan du gøre følgende:

I G1 skrives den værdi, du søger efter (i dit spørgsmål "s").

I kolonne D skrives denne formel (træk nedad fra D1): =HVIS(A1=$G$1;C1;"")

I E1 skrives: =HVIS(D1="";"";D1)

I resten af kolonne E skrives (træk nedad fra E2): =HVIS(D2="";E1;E1&", "&D2)

Dit resultat beregnes af denne formel (som du kan skrive i en hvilken som helst tom celle): =INDIREKTE("E"&TÆLV(E:E))

Det kræver lidt mellemregninger, men det virker... Hvis du har spørgsmål, skal du endelig skrive igen.

Simon

Godkendelse af svar
Fra : drdegn


Dato : 17-10-07 12:38

Tak for svaret sion. Det virker.

Jeg har lige et ekstra spørgsmål, som jeg ikke er sikker på kan lade sig gøre:

Lad os antage at bogstaverne 'd' og 'h' har hver sin farve, d er altid rødt og h altid blåt, kan man beholde denne tekstformatering i slutresultatet, eller skal der laves en eller anden algoritme i slutformlen?

Kommentar
Fra : sion


Dato : 17-10-07 12:59

Nej, det tror jeg heller ikke, kan lade sig gøre...

Hvis man bruger =TEKST([værdi];[format]) er det muligt at indstille værdiens talformat, men farven kan ikke ændres. Dette kan ellers gøres i en celles formatering ved at skrive eksempelvis 0,00;[Rød]0,00 for at skrive negative tal med rød skrift.

Simon

Kommentar
Fra : sion


Dato : 17-10-07 13:08

Du bør i E2 og nedefter lave formlen om til følgende:

=HVIS(D2="";E1;HVIS(E1="";D2;E1&", "&D2))

Ellers kan der komme til at stå et komma først i resultatet, eksempelvis ", h".

Simon

Du har følgende muligheder
Eftersom du ikke er logget ind i systemet, kan du ikke skrive et indlæg til dette spørgsmål.

Hvis du ikke allerede er registreret, kan du gratis blive medlem, ved at trykke på "Bliv medlem" ude i menuen.
Søg
Reklame
Statistik
Spørgsmål : 173634
Tips : 31664
Nyheder : 719565
Indlæg : 6383595
Brugere : 218258

Månedens bedste
Årets bedste
Sidste års bedste