/ Forside/ Teknologi / Internet / Browser / Spørgsmål
Login
Glemt dit kodeord?
Brugernavn 

Kodeord  


Reklame
Top 10 brugere
Browser
#NavnPoint
Klaudi 18446
molokyle 11884
o.v.n. 8114
miritdk 4839
stl_s 3840
refi 3598
arlet 2470
tedd 2383
dk 2098
10  webnoob 2075
Internet Explorer (no add-ons)
Fra : metalfaust
Vist : 1958 gange
130 point
Dato : 27-06-07 15:59

For noget tid siden skiftede jeg til Mozilla Firefox grundet Internet Explorers (v7.0) træghed. Jeg gjorde dengang Firefox til min default-browser. Og nu står der, at IE har no add-ons. Hvad værre er, at jeg ikke kan bruge Danske Banks netbank eller andre netbanker (får specifikt at vide, at jeg ikke har Java, selvom jeg har det). Nogen som kender til det problem? Det er sikkert meget let at løse, for inden Firefox fungerede det jo fint nok.

 
 
Kommentar
Fra : stl_s


Dato : 27-06-07 16:05

Jeg tror at du bliver nødt til at geninstallere IE7 http://www.microsoft.com/downloads/details.aspx?FamilyId=9AE91EBE-3385-447C-8A30-081805B2F90B&displaylang=da

Og Java måske også.

Kommentar
Fra : stl_s


Dato : 27-06-07 16:09

Husk at tjekke Windows Update bagefter. Måske flere gange.

Kommentar
Fra : molokyle


Dato : 28-06-07 09:13

Det kan også være du har fået deaktiveret plug-ins i IE7 ved at gøre Firefox til standardbrowser.

Åbn IE7 og vælg menuen:

Funktioner->Administrer tilføjelses programmer->Aktiver eller deaktiver tilføjelsesprogrammer->.. vælg rullemenuen->Tilføjelsesprogrammer som er indlæst i explorer i øjeblikket-> ..find og mærk Sun Java Console af og sæt 'prik' i aktiver. Gør det samme med SSVHelper Class.

..begge er en del af ssv.dll

Gå nu ind på en side med en Java applet, så skuller der i samme menu kunne ses et plug in som hedder Java Plug-in 1.6.0_01 (..stadig ssv.dll) og aktiver.

Grunden til siden (..med applet'en) ikke virker i Firefox er nok at programmørene af siden ikke har implementeret plug-in'et korrekt. Det er nemlig ikke helt ukompliceret at gøre hvis det skal virke på alle platforme. På min egen 404 fejl side kan du teste Java i alle browsere. Kan du høre lyden på denne side, så virker Java:

http://www.cssboxing.com/DETTE_GIVER_EN_FEJL

</MOLOKYLE>

Kommentar
Fra : metalfaust


Dato : 02-07-07 09:12

Hej Molekyle. Har været bortrejst og så først dit svar nu. Mit IE 7.0 er på engelsk, så jeg kan ikke rigtig finde de funktioner du taler om...

Kommentar
Fra : metalfaust


Dato : 10-07-07 09:04

Er der virkelig ingen, der kan hjælpe?

Kommentar
Fra : molokyle


Dato : 10-07-07 09:12

Nu sidder jeg ikke lige med en engelsk version, men du vil kunne finde omtalte menuer under:

Tools->Internetoptions-> ..fanen; 'Programs' ..og så burde du komme frem til indstillingerne for plug-in's ved at klikke på knappen nederst.

</MOLOKYLE>

Kommentar
Fra : molokyle


Dato : 10-07-07 09:23

add-on's er iøvrigt noget andet end 3. part plug-in's som f.eks. Java og Flash

Microsoft add-on's til IE7 finder du her: http://www.windowsmarketplace.com/category.aspx?bcatid=834

..læs evt. mere her: http://blogs.msdn.com/ie/archive/2006/10/20/must-have-add-ons-for-ie7.aspx

</MOLOKYLE>

Kommentar
Fra : metalfaust


Dato : 11-07-07 08:40

Molekyle, når jeg går ind i IE og følger den fremgangsmåde, som du beskriver, kan jeg blot konstatere, at alt er "enabled". Dvs. problemet findes vel andetsteds. Jeg prøvede derefter at klikke på dit link (det hvor man kan se, om Java kan afspille lyd), og fik fejl. Betyder det, at det er min Java, som skal installeres påny, eller har du en ide om, hvad problemet ellers er?

Kommentar
Fra : molokyle


Dato : 11-07-07 09:18

Hvilken 'fejl' fik du? Der er ingen fejl på siden

Der er faktisk ingen scripts på siden som kan fejle. Jeg benytter kun XHTML 1.0, CSS level2 og en Java class (loop_lyd.class), hvor den specifikke <object> kode udmaskes til diverse browsere vha. betingede kommentarer:
Kode
<!--[if !IE]>-->
<object classid="java:loop_lyd.class" type="application/x-java-applet" height="0" width="0" >
<param name="codebase" value="/java/" />
<param name="sound" value="/media/au/PsalmietCantica.au" />
<!--<![endif]-->
<object classid="clsid:8AD9C840-044E-11D1-B3E9-00805F499D93" width="0" height="0">
<param name="code" value="loop_lyd.class" />
<param name="codebase" value="/java/" />
<param name="sound" value="/media/au/PsalmietCantica.au" />
</object>
<!--[if !IE]>-->
</object>
<!--<![endif]-->


Java klassen har jeg også selv skrevet og compileret:
Kode
import java.applet.*;

public class loop_lyd extends java.applet.Applet {

private AudioClip lyd;

public void init()
{
lyd=getAudioClip(getCodeBase(),getParameter("sound"));
}

public void start()
{
lyd.loop();
}

public void stop()
{
lyd.stop();
}
}


Noget kunne rigtigt nok tyde på, at det er din Java installation som fejler

På denne side kan du teste din Java installation: http://www.znn.dk/

Duer din Java ikke?

1.) Fjern den fra Kontrolpanel->Tilføj eller fjern programmer.

2.) Rens din registreringsdatabase med TweakNowRegCleaner Std. : http://www.tweaknow.com/RegCleaner.html

3.) Genstart.

4.) Hent og installér Java enten fra Pkt. 4 fra znn.dk eller herfra: http://java.com/ ..hvor du også kan teste din Java.

</MOLOKYLE>

Kommentar
Fra : metalfaust


Dato : 11-07-07 17:53

Hej igen. Det var vist mig der var lidt for hurtig der. Den side med lyden på virker fint i Firefox; men i IE virker den ikke, dvs. ingen lyd der. Dvs. Java virker ok, I guess....

I IE, når jeg åbner browseren, får jeg blot beskeden "Internet Explorer is currently running with add-ons disabled", og som regel skal jeg trykke på opdater, for overhovedet at komme til min startside.

Ved ikke helt, hvad jeg skal gøre...?

Kommentar
Fra : stl_s


Dato : 11-07-07 18:23

Citat
Internet Explorer is currently running with add-ons disabled


Så skulle du nok genaktivere tilføjelsesprogrammerne. Gå i IE -> Funktioner -> Administrer tilføjelsesprogrammer.

Kommentar
Fra : molokyle


Dato : 11-07-07 20:23

Ja... eller hvad nu browser-menuen hedder i en engelsk version af IE 7

http://www.kandu.dk/spg106289.aspx#1194060

</MOLOKYLE>



Kommentar
Fra : stl_s


Dato : 11-07-07 20:56

Nåh ja, okay

Kommentar
Fra : metalfaust


Dato : 12-07-07 12:18

Jeg må nok tilstå, at jeg er lidt på bar bund.

- Java virker ok - i hvert fald iflg. testen på dit site, molokyle

- IE is currently running with add-ons disabled... men, når jeg går ind i tools > internet options > programs > manage add-ons, så er alt enabled. Jeg kører Firefox som default browser, og problemet med, at jeg ikke kunne bruge netbank osv. opstod, da jeg installerede Firefox. Grunden til at jeg installerede Firefox var den meget højere hastighed, som dette program kører på sammenlignet med IE 7.0 (der i 50% af tilfældene ikke kunne vise sites). Så det jeg tror er løsningen er at bruge IE til netbank og den slags, men det kan jeg jo ikke, da det ikke virker.

Kommentar
Fra : stl_s


Dato : 12-07-07 13:24

Prøv at se mit forslag 27-06-07 16:05. Det er nok eneste løsning. Det er faktisk ikke engang besværligt. Filen afinstallerer den gamle IE7, bevarer de fleste af dine indstillinger, og geninstallerer så IE ved genstart, inden dine andre programmer er loadet.

Kommentar
Fra : molokyle


Dato : 13-07-07 08:45

Ja, det bli'r såmen nok løsningen at gøre som stl_s anbefaler

Selv benytter jeg:

1.) IE7 7.0.5730.11
2.) Nestscape 8.1.3
3.) Opera 9.2.1 build 8776
4.) Safari 3.0.2 build 522.13.1
5.) Firefox 2.0.0.3

Jeg kører ind imellem med flere af disse åbne samtidig og Java 1.6.0_01 virker i dem alle.

På trods af diverse benchmark test bemærker jeg sjældent forskel i load-/renderingshastigheden af en hjemmeside. Der er dog stor variation i, hvorledes forskellige hjemmesider præsenteres, da der er grundlæggende forskelle i såvel Javascript fortolkerens og DOM's implementation, som i understøttelsen af CSS ..i de forskellige browsere. De har alle deres stærke og svage sider, men INGEN af dem overholder til punkt og prikke standard specifikationerne som anbefalet af www.w3.org/

IE fra Microsoft har som den 'værste' forurenet internettets hjemmesider med proprietærer HTML markører og parametre, som ikke 'forstås' af andre end ....Microsoft. Da folk ofte kun tester deres sider med denne browser, er der ikke noget at sige til det enten ikke virker ..eller ser højst besynderligt ud i alle andre browsere

</MOLOKYLE>

Kommentar
Fra : metalfaust


Dato : 13-07-07 22:41

Ok det prøver jeg, så får vi se, hvor det bærer hen. Forhåbentlig et godt sted

Du har følgende muligheder
Dette spørgsmål er blevet annulleret, det er derfor ikke muligt for at tilføje flere kommentarer.
Søg
Reklame
Statistik
Spørgsmål : 173637
Tips : 31664
Nyheder : 719565
Indlæg : 6383623
Brugere : 218258

Månedens bedste
Årets bedste
Sidste års bedste