/ Forside/ Teknologi / Administrative / MS-Office / Spørgsmål
Login
Glemt dit kodeord?
Brugernavn 

Kodeord  


Reklame
Top 10 brugere
MS-Office
#NavnPoint
sion 18609
refi 14474
Klaudi 8489
Rosco40 5695
berpox 5456
dk 5398
webnoob 4919
Benjamin... 4870
o.v.n. 4637
10  EXTERMINA.. 4373
Excel - logisk summation
Fra : kondivand
Vist : 813 gange
50 point
Dato : 23-06-10 11:47

Jeg har et regneark, hvor jeg bruger formlen SUM.HVIS til at undersøge om en given tekst findes i et stort antal rækker, og herefter summe sammen i en udvalgt kolonne.

Nu vil jeg gerne have, at SUM.HVIS kun skal udføres, hvis i de situationer, hvor den samtidige finder en ensartet tekst, som står i hver sin kolonne. Indtil nu så undersøger excel om Q2 findes i kolonne D5-D4000. Hver gang den finder værdien Q2, så skal den snuppe værdien i samme række blot i en anden kolonne.

Nu ønsker jeg, at den kun skal udføre ovenstående, hvis den yderligere tjekker om f.eks. R2 samtidig findes i kolonne C5-C4000 - altså hver gang den finder Q2 i Kolonne D5-D4000, så skal den samtidig tjekke om teksten i R2 også findes i samme række som den finder Q2.

Håber det er til at forstå:

Pointen er altså kun udfør SUM.HVIS i de situationer, hvor yderligere en betingelse er opfyldt.

 
 
Kommentar
Fra : kondivand


Dato : 23-06-10 12:57

Der er tale om Excel 2003, og jeg tror ikke SUM.HVISER eksisterer?

Kommentar
Fra : sion


Dato : 23-06-10 16:15

Når du nu ikke har mulighed for at bruge SUM.HVISER, er det nemmeste at lave en ekstra kolonne til mellemregninger. I denne kolonnes celle i række 5 skriver du følgende formel og trækker den nedad:

=HVIS(OG(D5=$Q$2;C5=$R$2);SAND;FALSK)

Herefter kan du i din SUM.HVIS-formel summere de rækker, hvor værdien i din nye kolonne er SAND.

Simon

Accepteret svar
Fra : Rosco40

Modtaget 50 point
Dato : 27-06-10 12:41

Du kan også samle det i en celle.
Hvis nu det der skal sammentælles er i kolonne A.

SUMPRODUKT($A$5:$A$5000)*($D$5:$D$5000=$Q$2)*($C$5:$C$5000=$R$2)


Godkendelse af svar
Fra : kondivand


Dato : 11-07-10 11:09

Tak for svaret Rosco40.

Du har følgende muligheder
Eftersom du ikke er logget ind i systemet, kan du ikke skrive et indlæg til dette spørgsmål.

Hvis du ikke allerede er registreret, kan du gratis blive medlem, ved at trykke på "Bliv medlem" ude i menuen.
Søg
Reklame
Statistik
Spørgsmål : 176405
Tips : 31892
Nyheder : 719565
Indlæg : 6401425
Brugere : 218693

Månedens bedste
Årets bedste
Sidste års bedste